What’s Vulnerable › Vulnerabilities
CVE-2020-20739
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-11-20 · updated 2026-06-17
- Weakness: CWE-909
Description
im_vips2dz in /libvips/libvips/deprecated/im_vips2dz.c in libvips before 8.8.2 has an uninitialized variable which may cause the leakage of remote server path or stack address.
Affected products
- Debian Linux: 9.0
- Fedoraproject Fedora: 32
- libvips: before 8.8.2 — fixed in 8.8.2
How to fix
Upgrade to a fixed version: libvips 8.8.2. Check the vendor advisory for mitigations.
References
- https://github.com/libvips/libvips/commit/2ab5aa7bf515135c2b02d42e9a72e4c98e17031a
- https://github.com/libvips/libvips/issues/1419
- https://lists.debian.org/debian-lts-announce/2020/11/msg00049.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZULVPQQ4QDFSQCXFYBUXEM7UXJAOKLSP/
- https://github.com/libvips/libvips/commit/2ab5aa7bf515135c2b02d42e9a72e4c98e17031a
- https://github.com/libvips/libvips/issues/1419
- https://lists.debian.org/debian-lts-announce/2020/11/msg00049.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZULVPQQ4QDFSQCXFYBUXEM7UXJAOKLSP/
Get alerted when CVE-2020-20739 or the next vulnerability affects your stack