What’s Vulnerable › Vulnerabilities
CVE-2020-22336
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-06 · updated 2026-06-17
- Weakness: CWE-787
Description
An issue was discovered in pdfcrack 0.17 thru 0.18, allows attackers to execute arbitrary code via a stack overflow in the MD5 function.
Affected products
- Pdfcrack Project Pdfcrack: from 0.17 before 0.19 — fixed in 0.19
How to fix
Upgrade to a fixed version: Pdfcrack Project Pdfcrack 0.19. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2023/08/msg00004.html
- https://sourceforge.net/p/pdfcrack/bugs/12/
- https://lists.debian.org/debian-lts-announce/2023/08/msg00004.html
- https://sourceforge.net/p/pdfcrack/bugs/12/
Get alerted when CVE-2020-22336 or the next vulnerability affects your stack