What’s Vulnerable › Vulnerabilities
CVE-2020-22452
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-26 · updated 2026-07-09
- Weakness: CWE-89
Description
SQL Injection vulnerability in function getTableCreationQuery in CreateAddField.php in phpMyAdmin 5.x before 5.2.0 via the tbl_storage_engine or tbl_collation parameters to tbl_create.php.
Affected products
- phpMyAdmin: from 5.0.0 before 5.2.0 — fixed in 5.2.0
How to fix
Upgrade to a fixed version: phpMyAdmin 5.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/phpmyadmin/phpmyadmin/blob/master/ChangeLog
- https://github.com/phpmyadmin/phpmyadmin/issues/15898
- https://github.com/phpmyadmin/phpmyadmin/pull/16004
- https://github.com/phpmyadmin/phpmyadmin/blob/master/ChangeLog
- https://github.com/phpmyadmin/phpmyadmin/issues/15898
- https://github.com/phpmyadmin/phpmyadmin/pull/16004
Get alerted when CVE-2020-22452 or the next vulnerability affects your stack