What’s Vulnerable › Vulnerabilities
CVE-2020-22781
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-28 · updated 2026-06-17
- Weakness: CWE-89
Description
In Etherpad < 1.8.3, a specially crafted URI would raise an unhandled exception in the cache mechanism and cause a denial of service (crash the instance).
Affected products
- etherpad-lite: before 1.8.3 — fixed in 1.8.3
How to fix
Upgrade to a fixed version: etherpad-lite 1.8.3. Check the vendor advisory for mitigations.
References
- https://github.com/ether/etherpad-lite/issues/3502
- https://github.com/ether/etherpad-lite/issues/3502
Get alerted when CVE-2020-22781 or the next vulnerability affects your stack