What’s Vulnerable › Vulnerabilities
CVE-2020-22783
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-28 · updated 2026-06-17
- Weakness: CWE-312
Description
Etherpad <1.8.3 stored passwords used by users insecurely in the database and in log files. This affects every database backend supported by Etherpad.
Affected products
- etherpad-lite: before 1.8.3 — fixed in 1.8.3
How to fix
Upgrade to a fixed version: etherpad-lite 1.8.3. Check the vendor advisory for mitigations.
References
- https://github.com/ether/etherpad-lite/commit/53f126082a8b3d094e48b159f0f0bc8a5db4b2f4
- https://github.com/ether/etherpad-lite/issues/3421
- https://github.com/ether/etherpad-lite/commit/53f126082a8b3d094e48b159f0f0bc8a5db4b2f4
- https://github.com/ether/etherpad-lite/issues/3421
Get alerted when CVE-2020-22783 or the next vulnerability affects your stack