What’s Vulnerable › Vulnerabilities
CVE-2020-22785
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-28 · updated 2026-06-17
- Weakness: CWE-770
Description
Etherpad < 1.8.3 is affected by a missing lock check which could cause a denial of service. Aggressively targeting random pad import endpoints with empty data would flatten all pads due to lack of rate limiting and missing ownership check.
Affected products
- etherpad-lite: before 1.8.3 — fixed in 1.8.3
How to fix
Upgrade to a fixed version: etherpad-lite 1.8.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-22785 or the next vulnerability affects your stack