What’s Vulnerable › Vulnerabilities
CVE-2020-22873
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-13 · updated 2026-06-17
- Weakness: CWE-120
Description
Buffer overflow vulnerability in function NumberToPrecisionCmd in jsish before 3.0.7, allows remote attackers to execute arbitrary code.
Affected products
- Jsish Jsi: before 3.0.7 — fixed in 3.0.7
How to fix
Upgrade to a fixed version: Jsish Jsi 3.0.7. Check the vendor advisory for mitigations.
References
- https://github.com/pcmacdon/jsish/commit/430ea27accd4d4ffddc946c9402e7c9064835a18
- https://github.com/pcmacdon/jsish/commit/430ea27accd4d4ffddc946c9402e7c9064835a18
Get alerted when CVE-2020-22873 or the next vulnerability affects your stack