What’s Vulnerable › Vulnerabilities
CVE-2020-22874
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-07-13 · updated 2026-06-17
- Weakness: CWE-190
Description
Integer overflow vulnerability in function Jsi_ObjArraySizer in jsish before 3.0.8, allows remote attackers to execute arbitrary code.
Affected products
- Jsish Jsi: before 3.0.8 — fixed in 3.0.8
How to fix
Upgrade to a fixed version: Jsish Jsi 3.0.8. Check the vendor advisory for mitigations.
References
- https://github.com/pcmacdon/jsish/commit/858da537bde4de9d8c92466d5a866505310bc328
- https://github.com/pcmacdon/jsish/issues/5
- https://github.com/pcmacdon/jsish/commit/858da537bde4de9d8c92466d5a866505310bc328
- https://github.com/pcmacdon/jsish/issues/5
Get alerted when CVE-2020-22874 or the next vulnerability affects your stack