What’s Vulnerable › Vulnerabilities
CVE-2020-24164
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-11 · updated 2026-06-17
- Weakness: CWE-502
Description
A deserialization flaw is present in Taoensso Nippy before 2.14.2. In some circumstances, it is possible for an attacker to create a malicious payload that, when deserialized, will allow arbitrary code to be executed. This occurs because there is automatic use of the Java Serializable interface.
Affected products
- Taoensso Nippy: before 2.14.2 — fixed in 2.14.2
How to fix
Upgrade to a fixed version: Taoensso Nippy 2.14.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-24164 or the next vulnerability affects your stack