What’s Vulnerable › Vulnerabilities
CVE-2020-24361
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-16 · updated 2026-06-17
- Weakness: CWE-273
Description
SNMPTT before 1.4.2 allows attackers to execute shell code via EXEC, PREXEC, or unknown_trap_exec.
Affected products
- Debian Linux: 9.0
- Snmptt: before 1.4.2 — fixed in 1.4.2
How to fix
Upgrade to a fixed version: Snmptt 1.4.2. Check the vendor advisory for mitigations.
References
- http://www.snmptt.org/changelog.shtml
- https://lists.debian.org/debian-lts-announce/2020/10/msg00006.html
- https://security.gentoo.org/glsa/202007-63
- http://www.snmptt.org/changelog.shtml
- https://lists.debian.org/debian-lts-announce/2020/10/msg00006.html
- https://security.gentoo.org/glsa/202007-63
Get alerted when CVE-2020-24361 or the next vulnerability affects your stack