What’s Vulnerable › Vulnerabilities
CVE-2020-24384
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-11-10 · updated 2026-06-17
Description
A10 Networks ACOS and aGalaxy management Graphical User Interfaces (GUIs) have an unauthenticated Remote Code Execution (RCE) vulnerability that could be used to compromise affected ACOS systems. ACOS versions 3.2.x (including and after 3.2.2), 4.x, and 5.1.x are affected. aGalaxy versions 3.0.x, 3.2.x, and 5.0.x are affected.
Affected products
- A10Networks Advanced Core Operating System: 3.2.2, 3.2.2-p8, 3.2.3, 3.2.3-p5, 3.2.4, 3.2.4-p5 (+16)
- A10Networks Agalaxy: from 3.2.1 through 3.2.4; from 5.0.1 before 5.0.5; 3.0.1, 3.0.4-p3, 5.0.5 — fixed in 5.0.5
How to fix
Upgrade to a fixed version: A10Networks Agalaxy 5.0.5. Check the vendor advisory for mitigations.
References
- https://support.a10networks.com/support/security_advisory/acos-agalaxy-gui-rce-vulnerability-cve-2020-24384
- https://support.a10networks.com/support/security_advisory/acos-agalaxy-gui-rce-vulnerability-cve-2020-24384
Get alerted when CVE-2020-24384 or the next vulnerability affects your stack