What’s Vulnerable › Vulnerabilities
CVE-2020-24394
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-19 · updated 2026-06-17
- Weakness: CWE-732
Description
In the Linux kernel before 5.7.8, fs/nfsd/vfs.c (in the NFS server) can set incorrect permissions on new filesystem objects when the filesystem lacks ACL support, aka CID-22cf8419f131. This occurs because the current umask is not considered.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 20.04
- Linux kernel: before 5.7.8 — fixed in 5.7.8
- openSUSE Leap: 15.1
- Oracle Corporation SD-WAN Edge: 8.2
- Starwindsoftware Starwind Virtual San: v8-build12533, v8-build12658, v8-build12859, v8-build13170, v8-build13586, v8-build13861
How to fix
Upgrade to a fixed version: Linux kernel 5.7.8. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00007.html
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=962254
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.7.8
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=22cf8419f1319ff87ec759d0ebdff4cbafaee832
- https://security.netapp.com/advisory/ntap-20200904-0003/
- https://usn.ubuntu.com/4465-1/
- https://usn.ubuntu.com/4483-1/
- https://usn.ubuntu.com/4485-1/
- https://www.oracle.com/security-alerts/cpuApr2021.html
- https://www.starwindsoftware.com/security/sw-20210325-0004/
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00007.html
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=962254
Get alerted when CVE-2020-24394 or the next vulnerability affects your stack