What’s Vulnerable › Vulnerabilities
CVE-2020-24400: SQL injection allows arbitrary read from database
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-11-09 · updated 2026-06-17
- Weakness: CWE-89
Description
Magento versions 2.4.0 and 2.3.5 (and earlier) are affected by an SQL Injection vulnerability that could lead to sensitive information disclosure. This vulnerability could be exploited by an authenticated user with permissions to the product listing page to read data from the database.
Affected products
- Adobe Magento Commerce: before 2.3.5; 2.3.5, 2.4.0 — fixed in 2.3.5
How to fix
Upgrade to a fixed version: Adobe Magento Commerce 2.3.5. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/magento/apsb20-59.html
- https://helpx.adobe.com/security/products/magento/apsb20-59.html
Get alerted when CVE-2020-24400 or the next vulnerability affects your stack