What’s Vulnerable › Vulnerabilities
CVE-2020-24402: Incorrect permissions in the Integrations component could lead to unauthorized deletion of customer details via REST API
- Severity: medium (CVSS 5.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-11-09 · updated 2026-06-17
- Weakness: CWE-276
Description
Magento version 2.4.0 and 2.3.5p1 (and earlier) are affected by an incorrect permissions vulnerability in the Integrations component. This vulnerability could be abused by authenticated users with permissions to the Resource Access API to delete customer details via the REST API without authorization.
Affected products
- Adobe Magento Commerce: before 2.3.5; 2.3.5, 2.3.5-p1, 2.4.0 — fixed in 2.3.5
How to fix
Upgrade to a fixed version: Adobe Magento Commerce 2.3.5. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/magento/apsb20-59.html
- https://helpx.adobe.com/security/products/magento/apsb20-59.html
Get alerted when CVE-2020-24402 or the next vulnerability affects your stack