What’s Vulnerable › Vulnerabilities
CVE-2020-24403: Incorrect permissions could lead to unauthorized modification of inventory source data via REST API
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-11-09 · updated 2026-06-17
- Weakness: CWE-285
Description
Magento version 2.4.0 and 2.3.5p1 (and earlier) are affected by an incorrect user permissions vulnerability within the Inventory component. This vulnerability could be abused by authenticated users with Inventory and Source permissions to make unauthorized changes to inventory source data via the REST API.
Affected products
- Adobe Magento Commerce: before 2.3.5; 2.3.5, 2.3.5-p1, 2.4.0 — fixed in 2.3.5
How to fix
Upgrade to a fixed version: Adobe Magento Commerce 2.3.5. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/magento/apsb20-59.html
- https://helpx.adobe.com/security/products/magento/apsb20-59.html
Get alerted when CVE-2020-24403 or the next vulnerability affects your stack