What’s Vulnerable › Vulnerabilities
CVE-2020-24581
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 13.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-12-22 · updated 2026-06-17
- Weakness: CWE-78
Description
An issue was discovered on D-Link DSL-2888A devices with firmware prior to AU_2.31_V1.1.47ae55. It contains an execute_cmd.cgi feature (that is not reachable via the web user interface) that lets an authenticated user execute Operating System commands.
Affected products
- Dlink Dsl2888A Firmware: before au_2.31_v1.1.47ae55 — fixed in au_2.31_v1.1.47ae55
How to fix
Upgrade to a fixed version: Dlink Dsl2888A Firmware au_2.31_v1.1.47ae55. Check the vendor advisory for mitigations.
References
- https://www.trustwave.com/en-us/resources/blogs/spiderlabs-blog/d-link-multiple-security-vulnerabilities-leading-to-rce/
- https://www.trustwave.com/en-us/resources/security-resources/security-advisories/
- https://www.trustwave.com/en-us/resources/blogs/spiderlabs-blog/d-link-multiple-security-vulnerabilities-leading-to-rce/
- https://www.trustwave.com/en-us/resources/security-resources/security-advisories/
Get alerted when CVE-2020-24581 or the next vulnerability affects your stack