What’s Vulnerable › Vulnerabilities
CVE-2020-24634
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-11 · updated 2026-06-17
- Weakness: CWE-77
Description
An attacker is able to remotely inject arbitrary commands by sending especially crafted packets destined to the PAPI (Aruba Networks AP Management protocol) UDP port (8211) of access-pointsor controllers in Aruba 9000 Gateway; Aruba 7000 Series Mobility Controllers; Aruba 7200 Series Mobility Controllers version(s): 2.1.0.1, 2.2.0.0 and below; 6.4.4.23, 6.5.4.17, 8.2.2.9, 8.3.0.13, 8.5.0.10, 8.6.0.5, 8.7.0.0 and below ; 6.4.4.23, 6.5.4.17, 8.2.2.9, 8.3.0.13, 8.5.0.10, 8.6.0.5, 8.7.0.0 and below.
Affected products
- Hewlett Packard Enterprise (HPE) ArubaOS (AOS): before 8.2.2.10; from 8.3.0.0 before 8.3.0.14; from 8.4.0.0 before 8.5.0.11; from 8.6.0.0 before 8.6.0.6; from 8.7.0.0 before 8.7.1.0 — fixed in 8.2.2.10, 8.3.0.14, 8.5.0.11, 8.6.0.6, 8.7.1.0
- Arubanetworks Sd-Wan: before 2.1.0.2; from 2.2.0.0 before 2.2.0.1 — fixed in 2.1.0.2, 2.2.0.1
How to fix
Upgrade to a fixed version: Hewlett Packard Enterprise (HPE) ArubaOS (AOS) 8.2.2.10, 8.3.0.14, 8.5.0.11, 8.6.0.6; Arubanetworks Sd-Wan 2.1.0.2, 2.2.0.1. Check the vendor advisory for mitigations.
References
- https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbnw04072en_us
- https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbnw04072en_us
Get alerted when CVE-2020-24634 or the next vulnerability affects your stack