What’s Vulnerable › Vulnerabilities
CVE-2020-24635
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-29 · updated 2026-06-17
- Weakness: CWE-78
Description
A remote execution of arbitrary commands vulnerability was discovered in some Aruba Instant Access Point (IAP) products in version(s): Aruba Instant 6.5.x: 6.5.4.17 and below; Aruba Instant 8.3.x: 8.3.0.13 and below; Aruba Instant 8.5.x: 8.5.0.10 and below; Aruba Instant 8.6.x: 8.6.0.5 and below; Aruba Instant 8.7.x: 8.7.0.0 and below. Aruba has released patches for Aruba Instant that address this security vulnerability.
Affected products
- Arubanetworks Instant: from 6.5.0.0 before 6.5.4.18; from 8.3.0.0 before 8.3.0.14; from 8.5.0.0 before 8.5.0.11; from 8.6.0.0 before 8.6.0.6; from 8.7.0.0 before 8.7.1.0 — fixed in 6.5.4.18, 8.3.0.14, 8.5.0.11, 8.6.0.6, 8.7.1.0
- Siemens Scalance W1750D Firmware: from 8.7.0 before 8.7.1.3 — fixed in 8.7.1.3
How to fix
Upgrade to a fixed version: Arubanetworks Instant 6.5.4.18, 8.3.0.14, 8.5.0.11, 8.6.0.6; Siemens Scalance W1750D Firmware 8.7.1.3. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/pdf/ssa-723417.pdf
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2021-007.txt
- https://cert-portal.siemens.com/productcert/pdf/ssa-723417.pdf
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2021-007.txt
Get alerted when CVE-2020-24635 or the next vulnerability affects your stack