What’s Vulnerable › Vulnerabilities
CVE-2020-24742
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-09 · updated 2026-10-08
Description
An issue has been fixed in Qt versions 5.14.0 where QPluginLoader attempts to load plugins relative to the working directory, allowing attackers to execute arbitrary code via crafted files.
Affected products
- Qt: from 5.6.0 before 5.12.7; from 5.13.0 through 5.13.2 — fixed in 5.12.7
How to fix
Upgrade to a fixed version: Qt 5.12.7. Check the vendor advisory for mitigations.
References
- https://codereview.qt-project.org/c/qt/qtbase/+/280730
- https://codereview.qt-project.org/c/qt/qtbase/+/280730
Get alerted when CVE-2020-24742 or the next vulnerability affects your stack