What’s Vulnerable › Vulnerabilities
CVE-2020-24870
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-02 · updated 2026-06-17
- Weakness: CWE-787
Description
Libraw before 0.20.1 has a stack buffer overflow via LibRaw::identify_process_dng_fields in identify.cpp.
Affected products
- LibRaw: before 0.20.1 — fixed in 0.20.1
How to fix
Upgrade to a fixed version: LibRaw 0.20.1. Check the vendor advisory for mitigations.
References
- https://github.com/LibRaw/LibRaw/commit/4feaed4dea636cee4fee010f615881ccf76a096d
- https://github.com/LibRaw/LibRaw/issues/330
- https://security.gentoo.org/glsa/202208-07
- https://github.com/LibRaw/LibRaw/commit/4feaed4dea636cee4fee010f615881ccf76a096d
- https://github.com/LibRaw/LibRaw/issues/330
- https://security.gentoo.org/glsa/202208-07
Get alerted when CVE-2020-24870 or the next vulnerability affects your stack