What’s Vulnerable › Vulnerabilities
CVE-2020-24889
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-09-16 · updated 2026-06-17
- Weakness: CWE-120
Description
A buffer overflow vulnerability in LibRaw version < 20.0 LibRaw::GetNormalizedModel in src/metadata/normalize_model.cpp may lead to context-dependent arbitrary code execution.
Affected products
- LibRaw: before 0.20.0 — fixed in 0.20.0
How to fix
Upgrade to a fixed version: LibRaw 0.20.0. Check the vendor advisory for mitigations.
References
- https://github.com/LibRaw/LibRaw/issues/334
- https://security.gentoo.org/glsa/202010-05
- https://github.com/LibRaw/LibRaw/issues/334
- https://security.gentoo.org/glsa/202010-05
Get alerted when CVE-2020-24889 or the next vulnerability affects your stack