What’s Vulnerable › Vulnerabilities
CVE-2020-2490
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-11-16 · updated 2026-06-17
- Weakness: CWE-77
Description
If exploited, the command injection vulnerability could allow remote attackers to execute arbitrary commands. This issue affects: QNAP Systems Inc. QTS versions prior to 4.4.3.1421 on build 20200907.
Affected products
- QNAP QTS: before 4.4.3.1421 — fixed in 4.4.3.1421
How to fix
Upgrade to a fixed version: QNAP QTS 4.4.3.1421. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/en/security-advisory/qsa-20-09
- https://www.qnap.com/en/security-advisory/qsa-20-09
Get alerted when CVE-2020-2490 or the next vulnerability affects your stack