What’s Vulnerable › Vulnerabilities
CVE-2020-24902
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-07 · updated 2026-06-17
- Weakness: CWE-79
Description
Quixplorer <=2.4.1 is vulnerable to reflected cross-site scripting (XSS) caused by improper validation of user supplied input. A remote attacker could exploit this vulnerability using a specially crafted URL to execute a script in a victim's Web browser within the security context of the hosting Web site, once the URL is clicked. An attacker could use this vulnerability to steal the victim's cookie-based authentication credentials.
Affected products
- Quixplorer Project Quixplorer: before 2.4.1; 2.4.1-beta — fixed in 2.4.1
How to fix
Upgrade to a fixed version: Quixplorer Project Quixplorer 2.4.1. Check the vendor advisory for mitigations.
References
- https://dl.packetstormsecurity.net/1804-exploits/quixplorer241beta-xss.txt
- https://dl.packetstormsecurity.net/1804-exploits/quixplorer241beta-xss.txt
Get alerted when CVE-2020-24902 or the next vulnerability affects your stack