What’s Vulnerable › Vulnerabilities
CVE-2020-2491: Cross-site Scripting Vulnerability in Photo Station
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-10 · updated 2026-06-17
- Weakness: CWE-79
Description
This cross-site scripting vulnerability in Photo Station allows remote attackers to inject malicious code. QANP We have already fixed this vulnerability in the following versions of Photo Station. QTS 4.5.1: Photo Station 6.0.12 and later QTS 4.4.3: Photo Station 6.0.12 and later QTS 4.3.6: Photo Station 5.7.12 and later QTS 4.3.4: Photo Station 5.7.13 and later QTS 4.3.3: Photo Station 5.4.10 and later QTS 4.2.6: Photo Station 5.2.11 and later
Affected products
- QNAP Systems Inc. Photo Station: before 6.0.12; before 5.7.12; before 5.7.13; before 5.4.10; before 5.2.11 — fixed in 5.2.11, 5.4.10, 5.7.12, 5.7.13, 6.0.12
How to fix
Upgrade to a fixed version: QNAP Systems Inc. Photo Station 5.2.11, 5.4.10, 5.7.12, 5.7.13. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/en/security-advisory/qsa-20-15
- https://www.qnap.com/en/security-advisory/qsa-20-15
Get alerted when CVE-2020-2491 or the next vulnerability affects your stack