What’s Vulnerable › Vulnerabilities
CVE-2020-24941: Improper Input Validation in Laravel
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-04 · updated 2026-06-17
- Weakness: CWE-863
Description
An issue was discovered in Laravel before 6.18.35 and 7.x before 7.24.0. The $guarded property is mishandled in some situations involving requests with JSON column nesting expressions.
Affected products
- Laravel Framework: before 6.18.35; from 7.0.0 before 7.24.0 — fixed in 6.18.35, 7.24.0
- Packagist Laravel/Framework: before 6.18.35; from 7.0.0 before 7.24.0; 5.0.30, 5.2.41, v4.0.0, v4.0.0-BETA2, v4.0.0-BETA3, v4.0.0-BETA4 (+551) — fixed in 6.18.35, 7.24.0
How to fix
Upgrade to a fixed version: Laravel Framework 6.18.35, 7.24.0; Packagist Laravel/Framework 6.18.35, 7.24.0. Check the vendor advisory for mitigations.
References
- https://blog.laravel.com/security-release-laravel-61835-7240
- https://blog.laravel.com/security-release-laravel-61835-7240
Get alerted when CVE-2020-24941 or the next vulnerability affects your stack