What’s Vulnerable › Vulnerabilities
CVE-2020-24948
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 13.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-09-03 · updated 2026-06-17
- Weakness: CWE-434
Description
The ao_ccss_import AJAX call in Autoptimize Wordpress Plugin 2.7.6 does not ensure that the file provided is a legitimate Zip file, allowing high privilege users to upload arbitrary files, such as PHP, leading to remote command execution.
Affected products
- Autoptimize: before 2.7.7 — fixed in 2.7.7
How to fix
Upgrade to a fixed version: Autoptimize 2.7.7. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/160850/WordPress-Autoptimize-Shell-Upload.html
- https://wpvulndb.com/vulnerabilities/10372
- http://packetstormsecurity.com/files/160850/WordPress-Autoptimize-Shell-Upload.html
- https://wpvulndb.com/vulnerabilities/10372
Get alerted when CVE-2020-24948 or the next vulnerability affects your stack