What’s Vulnerable › Vulnerabilities
CVE-2020-2498: Cross-site scripting vulnerability in QTS and QuTS hero
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-10 · updated 2026-06-17
- Weakness: CWE-79
Description
If exploited, this cross-site scripting vulnerability could allow remote attackers to inject malicious code in certificate configuration. QANP have already fixed these vulnerabilities in the following versions of QTS and QuTS hero. QuTS hero h4.5.1.1472 build 20201031 and later QTS 4.5.1.1456 build 20201015 and later QTS 4.4.3.1354 build 20200702 and later QTS 4.3.6.1333 build 20200608 and later QTS 4.3.4.1368 build 20200703 and later QTS 4.3.3.1315 build 20200611 and later QTS 4.2.6 build 20200611 and later
Affected products
- QNAP QTS: before 4.5.1.1456; before 4.4.3.1354; before 4.3.6.1333; before 4.3.4.1368; before 4.3.3.1315; before 4.2.6 — fixed in 4.2.6, 4.3.3.1315, 4.3.4.1368, 4.3.6.1333, 4.4.3.1354, 4.5.1.1456
- QNAP Systems Inc. QuTS hero: before h4.5.1.1472 — fixed in h4.5.1.1472
How to fix
Upgrade to a fixed version: QNAP QTS 4.2.6, 4.3.3.1315, 4.3.4.1368, 4.3.6.1333; QNAP Systems Inc. QuTS hero h4.5.1.1472. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/en/security-advisory/qsa-20-12
- https://www.qnap.com/en/security-advisory/qsa-20-12
Get alerted when CVE-2020-2498 or the next vulnerability affects your stack