What’s Vulnerable › Vulnerabilities
CVE-2020-24994
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-23 · updated 2026-06-17
- Weakness: CWE-770
Description
Stack overflow in the parse_tag function in libass/ass_parse.c in libass before 0.15.0 allows remote attackers to cause a denial of service or remote code execution via a crafted file.
Affected products
- Libass Project Libass: before 0.15.0 — fixed in 0.15.0
How to fix
Upgrade to a fixed version: Libass Project Libass 0.15.0. Check the vendor advisory for mitigations.
References
- https://github.com/libass/libass/commit/6835731c2fe4164a0c50bc91d12c43b2a2b4e
- https://github.com/libass/libass/issues/422
- https://github.com/libass/libass/issues/422#issuecomment-806002919
- https://github.com/libass/libass/issues/423
- https://github.com/libass/libass/commit/6835731c2fe4164a0c50bc91d12c43b2a2b4e
- https://github.com/libass/libass/issues/422
- https://github.com/libass/libass/issues/422#issuecomment-806002919
- https://github.com/libass/libass/issues/423
Get alerted when CVE-2020-24994 or the next vulnerability affects your stack