What’s Vulnerable › Vulnerabilities
CVE-2020-25017
- Severity: high (CVSS 8.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-10-01 · updated 2026-06-17
Description
Envoy through 1.15.0 only considers the first value when multiple header values are present for some HTTP headers. Envoy’s setCopy() header map API does not replace all existing occurences of a non-inline header.
Affected products
- envoyproxy envoy: before 1.12.7; from 1.13.0 before 1.13.4; from 1.14.0 before 1.14.4; from 1.15.0 before 1.15.1 — fixed in 1.12.7, 1.13.4, 1.14.4, 1.15.1
How to fix
Upgrade to a fixed version: envoyproxy envoy 1.12.7, 1.13.4, 1.14.4, 1.15.1. Check the vendor advisory for mitigations.
References
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-2v25-cjjq-5f4w
- https://groups.google.com/forum/#%21forum/envoy-security-announce
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-2v25-cjjq-5f4w
- https://groups.google.com/forum/#%21forum/envoy-security-announce
Get alerted when CVE-2020-25017 or the next vulnerability affects your stack