What’s Vulnerable › Vulnerabilities
CVE-2020-2506: QNAP Helpdesk Improper Access Control Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-03-25
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-02-03 · updated 2026-06-17
- Weakness: CWE-284
Description
The vulnerability have been reported to affect earlier versions of QTS. If exploited, this improper access control vulnerability could allow attackers to compromise the security of the software by gaining privileges, or reading sensitive information. This issue affects: QNAP Systems Inc. Helpdesk versions prior to 3.0.3.
Affected products
- QNAP Systems Inc. Helpdesk: before 3.0.3 — fixed in 3.0.3
How to fix
Upgrade to a fixed version: QNAP Systems Inc. Helpdesk 3.0.3. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/zh-tw/security-advisory/qsa-20-08
- https://www.qnap.com/zh-tw/security-advisory/qsa-20-08
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2020-2506
Get alerted when CVE-2020-2506 or the next vulnerability affects your stack