What’s Vulnerable › Vulnerabilities
CVE-2020-2508: Command Injection Vulnerability in QTS and QuTS hero
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-01-11 · updated 2026-06-17
- Weakness: CWE-77
Description
A command injection vulnerability has been reported to affect QTS and QuTS hero. If exploited, this vulnerability allows attackers to execute arbitrary commands in a compromised application. QNAP have already fixed this vulnerability in the following versions: QTS 4.5.1.1456 build 20201015 (and later) QuTS hero h4.5.1.1472 build 20201031 (and later)
Affected products
- QNAP QTS: before 4.5.1.1456 — fixed in 4.5.1.1456
- QNAP Systems Inc. QuTS hero: before h4.5.1.1472 — fixed in h4.5.1.1472
How to fix
Upgrade to a fixed version: QNAP QTS 4.5.1.1456; QNAP Systems Inc. QuTS hero h4.5.1.1472. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/zh-tw/security-advisory/qsa-21-01
- https://www.qnap.com/zh-tw/security-advisory/qsa-21-01
Get alerted when CVE-2020-2508 or the next vulnerability affects your stack