What’s Vulnerable › Vulnerabilities
CVE-2020-2509: QNAP Network-Attached Storage (NAS) Command Injection Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-04-11
- EPSS: 34.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-17 · updated 2026-06-17
- Weakness: CWE-77
Description
A command injection vulnerability has been reported to affect QTS and QuTS hero. If exploited, this vulnerability allows attackers to execute arbitrary commands in a compromised application. We have already fixed this vulnerability in the following versions: QTS 4.5.2.1566 Build 20210202 and later QTS 4.5.1.1495 Build 20201123 and later QTS 4.3.6.1620 Build 20210322 and later QTS 4.3.4.1632 Build 20210324 and later QTS 4.3.3.1624 Build 20210416 and later QTS 4.2.6 Build 20210327 and later QuTS hero h4.5.1.1491 build 20201119 and later
Affected products
- QNAP QTS: before 4.2.6; from 4.3.5 before 4.3.6; from 4.4.0 before 4.5.1; 4.2.6, 4.2.6-build_20170517, 4.2.6-build_20190322, 4.2.6-build_20190730, 4.2.6-build_20190921, 4.2.6-build_20191107 (+74) — fixed in 4.2.6, 4.3.6, 4.5.1
- QNAP Systems Inc. QuTS hero: before h4.5.1; h4.5.1, h4.5.1.1472 — fixed in h4.5.1
How to fix
Upgrade to a fixed version: QNAP QTS 4.2.6, 4.3.6, 4.5.1; QNAP Systems Inc. QuTS hero h4.5.1. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/en/security-advisory/qsa-21-05
- https://www.qnap.com/en/security-advisory/qsa-21-05
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2020-2509
Get alerted when CVE-2020-2509 or the next vulnerability affects your stack