What’s Vulnerable › Vulnerabilities
CVE-2020-25097
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-19 · updated 2026-06-17
- Weakness: CWE-20
Description
An issue was discovered in Squid through 4.13 and 5.x through 5.0.4. Due to improper input validation, it allows a trusted client to perform HTTP Request Smuggling and access services otherwise forbidden by the security controls. This occurs for certain uri_whitespace configuration settings.
Affected products
- Debian Linux: 10.0
- Fedoraproject Fedora: 32, 33, 34
- Cloud Manager: all versions
- Squid: from 2.0 before 4.14; from 5.0.1 before 5.0.5 — fixed in 4.14, 5.0.5
How to fix
Upgrade to a fixed version: Squid 4.14, 5.0.5. Check the vendor advisory for mitigations.
References
- http://www.squid-cache.org/Versions/v4/changesets/SQUID-2020_11.patch
- http://www.squid-cache.org/Versions/v5/changesets/SQUID-2020_11.patch
- https://github.com/squid-cache/squid/security/advisories/GHSA-jvf6-h9gj-pmj6
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DJMDRVV677AJL4BZAOLCT5LMFCGBZTC2/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FBXFWKIGXPERDVQXG556LLPUOCMQGERC/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/O3RYBDMJCPYGOSURWDR3WJTE474UFT77/
- https://security.gentoo.org/glsa/202105-14
- https://security.netapp.com/advisory/ntap-20210727-0010/
- https://www.debian.org/security/2021/dsa-4873
- http://www.squid-cache.org/Versions/v4/changesets/SQUID-2020_11.patch
- http://www.squid-cache.org/Versions/v5/changesets/SQUID-2020_11.patch
- https://github.com/squid-cache/squid/security/advisories/GHSA-jvf6-h9gj-pmj6
Get alerted when CVE-2020-25097 or the next vulnerability affects your stack