What’s Vulnerable › Vulnerabilities
CVE-2020-25167: OSIsoft PI Vision Incorrect Authorization
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-18 · updated 2026-06-17
- Weakness: CWE-863
Description
OSIsoft PI Vision 2020 versions prior to 3.5.0 could disclose information to a user with insufficient privileges for an AF attribute.
Affected products
- OSIsoft PI Vision: before 3.5.0 — fixed in 3.5.0
How to fix
Upgrade to a fixed version: OSIsoft PI Vision 3.5.0. Check the vendor advisory for mitigations.
References
- https://www.cisa.gov/uscert/ics/advisories/icsa-20-315-02
- https://www.cisa.gov/uscert/ics/advisories/icsa-20-315-02
Get alerted when CVE-2020-25167 or the next vulnerability affects your stack