What’s Vulnerable › Vulnerabilities
CVE-2020-25191
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-11 · updated 2026-06-17
- Weakness: CWE-732
Description
Incorrect permissions are set by default for an API entry-point of a specific service, allowing a non-authenticated user to trigger a function that could reboot the CompactRIO (Driver versions prior to 20.5) remotely.
Affected products
- CompactRIO: before 20.5 — fixed in 20.5
How to fix
Upgrade to a fixed version: CompactRIO 20.5. Check the vendor advisory for mitigations.
References
- https://us-cert.cisa.gov/ics/advisories/icsa-20-338-01
- https://us-cert.cisa.gov/ics/advisories/icsa-20-338-01
Get alerted when CVE-2020-25191 or the next vulnerability affects your stack