What’s Vulnerable › Vulnerabilities
CVE-2020-25213: WordPress File Manager Plugin Remote Code Execution Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2021-11-03
- EPSS: 97.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-09-09 · updated 2026-06-17
- Weakness: CWE-434
Description
The File Manager (wp-file-manager) plugin before 6.9 for WordPress allows remote attackers to upload and execute arbitrary PHP code because it renames an unsafe example elFinder connector file to have the .php extension. This, for example, allows attackers to run the elFinder upload (or mkfile and put) command to write PHP code into the wp-content/plugins/wp-file-manager/lib/files/ directory. This was exploited in the wild in August and September 2020.
Affected products
- File Manager Pro: before 6.9 — fixed in 6.9
How to fix
Upgrade to a fixed version: File Manager Pro 6.9. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/160003/WordPress-File-Manager-6.8-Remote-Code-Execution.html
- http://packetstormsecurity.com/files/171650/WordPress-File-Manager-6.9-Shell-Upload.html
- https://github.com/w4fz5uck5/wp-file-manager-0day
- https://hotforsecurity.bitdefender.com/blog/wordpress-websites-attacked-via-file-manager-plugin-vulnerability-24048.html
- https://plugins.trac.wordpress.org/changeset/2373068
- https://seravo.com/blog/0-day-vulnerability-in-wp-file-manager/
- https://wordfence.com/blog/2020/09/700000-wordpress-users-affected-by-zero-day-vulnerability-in-file-manager-plugin/
- https://wordpress.org/plugins/wp-file-manager/#developers
- https://zdnet.com/article/millions-of-wordpress-sites-are-being-probed-attacked-with-recent-plugin-bug/
- http://packetstormsecurity.com/files/160003/WordPress-File-Manager-6.8-Remote-Code-Execution.html
- http://packetstormsecurity.com/files/171650/WordPress-File-Manager-6.9-Shell-Upload.html
- https://github.com/w4fz5uck5/wp-file-manager-0day
Get alerted when CVE-2020-25213 or the next vulnerability affects your stack