What’s Vulnerable › Vulnerabilities
CVE-2020-25245
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-02-09 · updated 2026-06-17
- Weakness: CWE-276
Description
A vulnerability has been identified in DIGSI 4 (All versions < V4.94 SP1 HF 1). Several folders in the %PATH% are writeable by normal users. As these folders are included in the search for dlls, an attacker could place dlls there with code executed by SYSTEM.
Affected products
- Siemens DIGSI 4: before 4.94; 4.94, 4.94-sp1 — fixed in 4.94
How to fix
Upgrade to a fixed version: Siemens DIGSI 4 4.94. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/pdf/ssa-536315.pdf
- https://us-cert.cisa.gov/ics/advisories/icsa-21-040-10
- https://cert-portal.siemens.com/productcert/pdf/ssa-536315.pdf
- https://us-cert.cisa.gov/ics/advisories/icsa-21-040-10
Get alerted when CVE-2020-25245 or the next vulnerability affects your stack