What’s Vulnerable › Vulnerabilities
CVE-2020-25269
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-11 · updated 2026-06-17
- Weakness: CWE-416
Description
An issue was discovered in InspIRCd 2 before 2.0.29 and 3 before 3.6.0. The pgsql module contains a use after free vulnerability. When combined with the sqlauth or sqloper modules, this vulnerability can be used for remote crashing of an InspIRCd server by any user able to connect to a server.
Affected products
- Debian Linux: 9.0, 10.0
- Inspircd: from 2.0 before 2.0.29; from 3.0 before 3.6.0 — fixed in 2.0.29, 3.6.0
How to fix
Upgrade to a fixed version: Inspircd 2.0.29, 3.6.0. Check the vendor advisory for mitigations.
References
- https://docs.inspircd.org/security/2020-01/
- https://github.com/inspircd/inspircd/compare/426d1c8...b3f1db9
- https://github.com/inspircd/inspircd/compare/v2.0.28...07d7dea
- https://lists.debian.org/debian-lts-announce/2020/09/msg00015.html
- https://www.debian.org/security/2020/dsa-4764
- https://docs.inspircd.org/security/2020-01/
- https://github.com/inspircd/inspircd/compare/426d1c8...b3f1db9
- https://github.com/inspircd/inspircd/compare/v2.0.28...07d7dea
- https://lists.debian.org/debian-lts-announce/2020/09/msg00015.html
- https://www.debian.org/security/2020/dsa-4764
Get alerted when CVE-2020-25269 or the next vulnerability affects your stack