What’s Vulnerable › Vulnerabilities
CVE-2020-25275
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-01-04 · updated 2026-06-17
- Weakness: CWE-20
Description
Dovecot before 2.3.13 has Improper Input Validation in lda, lmtp, and imap, leading to an application crash via a crafted email message with certain choices for ten thousand MIME parts.
Affected products
- Debian Linux: 10.0
- dovecot: before 2.3.13 — fixed in 2.3.13
- Fedoraproject Fedora: 32
How to fix
Upgrade to a fixed version: dovecot 2.3.13. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/160841/Dovecot-2.3.11.3-Denial-Of-Service.html
- http://seclists.org/fulldisclosure/2021/Jan/18
- http://www.openwall.com/lists/oss-security/2021/01/04/3
- https://dovecot.org/pipermail/dovecot-news/2021-January/000451.html
- https://dovecot.org/security
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GXDKFLOCUP7I4ELGQ2F4P5TGC6NXMYV7/
- https://security.gentoo.org/glsa/202101-01
- https://www.debian.org/security/2021/dsa-4825
- http://packetstormsecurity.com/files/160841/Dovecot-2.3.11.3-Denial-Of-Service.html
- http://seclists.org/fulldisclosure/2021/Jan/18
- http://www.openwall.com/lists/oss-security/2021/01/04/3
- https://dovecot.org/pipermail/dovecot-news/2021-January/000451.html
Get alerted when CVE-2020-25275 or the next vulnerability affects your stack