What’s Vulnerable › Vulnerabilities
CVE-2020-25630
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-08 · updated 2026-06-17
- Weakness: CWE-400
Description
A vulnerability was found in Moodle where the decompressed size of zip files was not checked against available user quota before unzipping them, which could lead to a denial of service risk. This affects versions 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. Fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.
Affected products
- Moodle: from 3.5.0 before 3.5.14; from 3.7.0 before 3.7.8; from 3.8.0 before 3.8.5; from 3.9.0 before 3.9.2 — fixed in 3.5.14, 3.7.8, 3.8.5, 3.9.2
How to fix
Upgrade to a fixed version: Moodle 3.5.14, 3.7.8, 3.8.5, 3.9.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-25630 or the next vulnerability affects your stack