What’s Vulnerable › Vulnerabilities
CVE-2020-25637
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-10-06 · updated 2026-06-17
- Weakness: CWE-415
Description
A double free memory issue was found to occur in the libvirt API, in versions before 6.8.0, responsible for requesting information about network interfaces of a running QEMU domain. This flaw affects the polkit access control driver. Specifically, clients connecting to the read-write socket with limited ACL permissions could use this flaw to crash the libvirt daemon, resulting in a denial of service, or potentially escalate their privileges on the system. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Affected products
- openSUSE Leap: 15.1, 15.2
- libvirt: before 6.8.0 — fixed in 6.8.0
How to fix
Upgrade to a fixed version: libvirt 6.8.0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00072.html
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00073.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1881037
- https://lists.debian.org/debian-lts-announce/2024/04/msg00000.html
- https://security.gentoo.org/glsa/202210-06
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00072.html
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00073.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1881037
- https://lists.debian.org/debian-lts-announce/2024/04/msg00000.html
- https://security.gentoo.org/glsa/202210-06
Get alerted when CVE-2020-25637 or the next vulnerability affects your stack