What’s Vulnerable › Vulnerabilities

CVE-2020-25643

Description

A flaw was found in the HDLC_PPP module of the Linux kernel in versions before 5.9-rc7. Memory corruption and a read overflow is caused by improper input validation in the ppp_cp_parse_cr function which can cause the system to crash or cause a denial of service. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 4.14.200, 4.19.148, 4.4.238, 4.9.238. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-25643 or the next vulnerability affects your stack