What’s Vulnerable › Vulnerabilities
CVE-2020-25644
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-10-06 · updated 2026-06-17
- Weakness: CWE-401
Description
A memory leak flaw was found in WildFly OpenSSL in versions prior to 1.1.3.Final, where it removes an HTTP session. It may allow the attacker to cause OOM leading to a denial of service. The highest threat from this vulnerability is to system availability.
Affected products
- OnCommand Insight: all versions
- NetApp OnCommand Workflow Automation: all versions
- NetApp Service Level Manager: all versions
- RedHat Data Grid: 8.0
- RedHat Jboss Data Grid: 7.0.0
- Red Hat JBoss EAP: 7.0.0
- RedHat Jboss Fuse: 7.0.0
- RedHat Openshift Application Runtimes: all versions
- Red Hat Single Sign-On: 7.0
- RedHat Wildfly Openssl: before 1.1.3 — fixed in 1.1.3
How to fix
Upgrade to a fixed version: RedHat Wildfly Openssl 1.1.3. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1885485
- https://github.com/wildfly-security/wildfly-openssl-natives/pull/4/files
- https://issues.redhat.com/browse/WFSSL-51
- https://security.netapp.com/advisory/ntap-20201016-0004/
- https://bugzilla.redhat.com/show_bug.cgi?id=1885485
- https://github.com/wildfly-security/wildfly-openssl-natives/pull/4/files
- https://issues.redhat.com/browse/WFSSL-51
- https://security.netapp.com/advisory/ntap-20201016-0004/
Get alerted when CVE-2020-25644 or the next vulnerability affects your stack