What’s Vulnerable › Vulnerabilities
CVE-2020-25660
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-11-23 · updated 2026-06-17
- Weakness: CWE-294
Description
A flaw was found in the Cephx authentication protocol in versions before 15.2.6 and before 14.2.14, where it does not verify Ceph clients correctly and is then vulnerable to replay attacks in Nautilus. This flaw allows an attacker with access to the Ceph cluster network to authenticate with the Ceph service via a packet sniffer and perform actions allowed by the Ceph service. This issue is a reintroduction of CVE-2018-1128, affecting the msgr2 protocol. The msgr 2 protocol is used for all communication except older clients that do not support the msgr2 protocol. The msgr1 protocol is not affected. The highest threat from this vulnerability is to confidentiality, integrity, and system availability.
Affected products
- Fedoraproject Fedora: 33
- ceph: before 14.2.14; from 15.0.0 before 15.2.6 — fixed in 14.2.14, 15.2.6
- Red Hat Ceph Storage: 2.0, 4.0
- Red Hat OpenShift Container Platform 4.18: 4.0
How to fix
Upgrade to a fixed version: ceph 14.2.14, 15.2.6. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1890354
- https://ceph.io/community/v15-2-6-octopus-released/
- https://ceph.io/releases/v14-2-14-nautilus-released/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UBC4KZ44QUQENTYZPVHORGL4K2KV5V4F/
- https://security.gentoo.org/glsa/202105-39
- https://bugzilla.redhat.com/show_bug.cgi?id=1890354
- https://ceph.io/community/v15-2-6-octopus-released/
- https://ceph.io/releases/v14-2-14-nautilus-released/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UBC4KZ44QUQENTYZPVHORGL4K2KV5V4F/
- https://security.gentoo.org/glsa/202105-39
Get alerted when CVE-2020-25660 or the next vulnerability affects your stack