What’s Vulnerable › Vulnerabilities
CVE-2020-25681
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 84.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-01-20 · updated 2026-06-17
- Weakness: CWE-122
Description
A flaw was found in dnsmasq before version 2.83. A heap-based buffer overflow was discovered in the way RRSets are sorted before validating with DNSSEC data. An attacker on the network, who can forge DNS replies such as that they are accepted as valid, could use this flaw to cause a buffer overflow with arbitrary data in a heap memory segment, possibly executing code on the machine. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Affected products
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 32, 33
- Simon Kelley dnsmasq: before 2.83 — fixed in 2.83
How to fix
Upgrade to a fixed version: Simon Kelley dnsmasq 2.83. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1881875
- https://lists.debian.org/debian-lts-announce/2021/03/msg00027.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/QGB7HL3OWHTLEPSMLDGOMXQKG3KM2QME/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WYW3IR6APUSKOYKL5FT3ACTIHWHGQY32/
- https://security.gentoo.org/glsa/202101-17
- https://www.debian.org/security/2021/dsa-4844
- https://www.jsof-tech.com/disclosures/dnspooq/
- https://bugzilla.redhat.com/show_bug.cgi?id=1881875
- https://lists.debian.org/debian-lts-announce/2021/03/msg00027.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/QGB7HL3OWHTLEPSMLDGOMXQKG3KM2QME/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WYW3IR6APUSKOYKL5FT3ACTIHWHGQY32/
- https://security.gentoo.org/glsa/202101-17
Get alerted when CVE-2020-25681 or the next vulnerability affects your stack