What’s Vulnerable › Vulnerabilities
CVE-2020-25695
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 46.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-11-16 · updated 2026-06-17
- Weakness: CWE-89
Description
A flaw was found in PostgreSQL versions before 13.1, before 12.5, before 11.10, before 10.15, before 9.6.20 and before 9.5.24. An attacker having permission to create non-temporary objects in at least one schema can execute arbitrary SQL functions under the identity of a superuser. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Affected products
- Debian Linux: 9.0
- PostgreSQL: before 9.5.24; from 9.6.0 before 9.6.20; from 10.0 before 10.15; from 11.0 before 11.10; from 12.0 before 12.5; from 13.0 before 13.1 — fixed in 10.15, 11.10, 12.5, 13.1, 9.5.24, 9.6.20
How to fix
Upgrade to a fixed version: PostgreSQL 10.15, 11.10, 12.5, 13.1. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1894425
- https://lists.debian.org/debian-lts-announce/2020/12/msg00005.html
- https://security.gentoo.org/glsa/202012-07
- https://security.netapp.com/advisory/ntap-20201202-0003/
- https://www.postgresql.org/support/security/
- https://bugzilla.redhat.com/show_bug.cgi?id=1894425
- https://lists.debian.org/debian-lts-announce/2020/12/msg00005.html
- https://security.gentoo.org/glsa/202012-07
- https://security.netapp.com/advisory/ntap-20201202-0003/
- https://www.postgresql.org/support/security/
Get alerted when CVE-2020-25695 or the next vulnerability affects your stack