What’s Vulnerable › Vulnerabilities
CVE-2020-25696
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-11-23 · updated 2026-06-17
- Weakness: CWE-183
Description
A flaw was found in the psql interactive terminal of PostgreSQL in versions before 13.1, before 12.5, before 11.10, before 10.15, before 9.6.20 and before 9.5.24. If an interactive psql session uses \gset when querying a compromised server, the attacker can execute arbitrary code as the operating system account running psql. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Affected products
- Debian Linux: 9.0
- PostgreSQL: from 9.5.0 before 9.5.24; from 9.6.0 before 9.6.20; from 10.0 before 10.15; from 11.0 before 11.10; from 12.0 before 12.5; from 13.0 before 13.1 — fixed in 10.15, 11.10, 12.5, 13.1, 9.5.24, 9.6.20
How to fix
Upgrade to a fixed version: PostgreSQL 10.15, 11.10, 12.5, 13.1. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1894430
- https://lists.debian.org/debian-lts-announce/2020/12/msg00005.html
- https://security.gentoo.org/glsa/202012-07
- https://www.postgresql.org/about/news/postgresql-131-125-1110-1015-9620-and-9524-released-2111/
- https://bugzilla.redhat.com/show_bug.cgi?id=1894430
- https://lists.debian.org/debian-lts-announce/2020/12/msg00005.html
- https://security.gentoo.org/glsa/202012-07
- https://www.postgresql.org/about/news/postgresql-131-125-1110-1015-9620-and-9524-released-2111/
Get alerted when CVE-2020-25696 or the next vulnerability affects your stack