What’s Vulnerable › Vulnerabilities
CVE-2020-25710
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-28 · updated 2026-10-14
- Weakness: CWE-617
Description
A flaw was found in OpenLDAP in versions before 2.4.56. This flaw allows an attacker who sends a malicious packet processed by OpenLDAP to force a failed assertion in csnNormalize23(). The highest threat from this vulnerability is to system availability.
Affected products
- Debian Linux: 9.0
- Fedoraproject Fedora: 33
- openldap: before 2.4.56 — fixed in 2.4.56
- Red Hat Enterprise Linux: 5.0, 6.0, 7.0
- RedHat Jboss Core Services: all versions
- Red Hat JBoss EAP: 5.0.0
- Red Hat JBoss Enterprise Web Server: 2.0.0
How to fix
Upgrade to a fixed version: openldap 2.4.56. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1899678
- https://git.openldap.org/openldap/openldap/-/commit/ab3915154e69920d480205b4bf5ccb2b391a0a1f#a2feb6ed0257c21c6672793ee2f94eaadc10c72c
- https://lists.apache.org/thread.html/r58af02e294bd07f487e2c64ffc0a29b837db5600e33b6e698b9d696b%40%3Cissues.bookkeeper.apache.org%3E
- https://lists.apache.org/thread.html/rf4c02775860db415b4955778a131c2795223f61cb8c6a450893651e4%40%3Cissues.bookkeeper.apache.org%3E
- https://lists.debian.org/debian-lts-announce/2020/12/msg00008.html
- https://security.netapp.com/advisory/ntap-20210716-0003/
- https://www.debian.org/security/2020/dsa-4792
- https://bugzilla.redhat.com/show_bug.cgi?id=1899678
- https://git.openldap.org/openldap/openldap/-/commit/ab3915154e69920d480205b4bf5ccb2b391a0a1f#a2feb6ed0257c21c6672793ee2f94eaadc10c72c
- https://lists.apache.org/thread.html/r58af02e294bd07f487e2c64ffc0a29b837db5600e33b6e698b9d696b%40%3Cissues.bookkeeper.apache.org%3E
- https://lists.apache.org/thread.html/rf4c02775860db415b4955778a131c2795223f61cb8c6a450893651e4%40%3Cissues.bookkeeper.apache.org%3E
- https://lists.debian.org/debian-lts-announce/2020/12/msg00008.html
Get alerted when CVE-2020-25710 or the next vulnerability affects your stack