What’s Vulnerable › Vulnerabilities
CVE-2020-25722
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-18 · updated 2026-06-17
- Weakness: CWE-863
Description
Multiple flaws were found in the way samba AD DC implemented access and conformance checking of stored data. An attacker could use this flaw to cause total domain compromise.
Affected products
- Canonical Ubuntu Linux: 18.04, 20.04, 21.04, 21.10
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 33, 34, 35
- Samba: from 4.0.0 before 4.13.14; from 4.14.0 before 4.14.10; from 4.15.0 before 4.15.2 — fixed in 4.13.14, 4.14.10, 4.15.2
How to fix
Upgrade to a fixed version: Samba 4.13.14, 4.14.10, 4.15.2. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2019764
- https://security.gentoo.org/glsa/202309-06
- https://www.samba.org/samba/security/CVE-2020-25722.html
- https://bugzilla.redhat.com/show_bug.cgi?id=2019764
- https://security.gentoo.org/glsa/202309-06
- https://www.samba.org/samba/security/CVE-2020-25722.html
Get alerted when CVE-2020-25722 or the next vulnerability affects your stack