What’s Vulnerable › Vulnerabilities
CVE-2020-25730
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-04 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross Site Scripting (XSS) vulnerability in ZoneMinder before version 1.34.21, allows remote attackers execute arbitrary code, escalate privileges, and obtain sensitive information via PHP_SELF component in classic/views/download.php.
Affected products
- zoneminder: before 1.34.21 — fixed in 1.34.21
How to fix
Upgrade to a fixed version: zoneminder 1.34.21. Check the vendor advisory for mitigations.
References
- https://github.com/ZoneMinder/zoneminder/commit/9268db14a79c4ccd444c2bf8d24e62b13207b413
- https://github.com/ZoneMinder/zoneminder/commit/9268db14a79c4ccd444c2bf8d24e62b13207b413
Get alerted when CVE-2020-25730 or the next vulnerability affects your stack